martes, 2 de noviembre de 2010

Emuladores de consolas de videojuegos en Linux ubuntu

Emuladores De Nintendo Ds:

IDeaS

Tienes que instalar las librerías GTK+ 2.0 + Cairo + Pango el emulador lo descargas de acá: http://ideasemu.biz/index.php?act=downloads.htm pero se darán de cuenta que no tiene sonido pues para resolver eso tienes que descargar los plugins de la pagina ya dada, acá hay otro link http://www.qj.net/qjnet/nintendo-ds/ds-homebrew-ideas-audio-and-wifi-plugin-1015-for-windows.html creo que el plugin wifi es de mayor versión en este link por cierto este fue el segundo emulador en poder usar el wifi aunque es beta y aun esta en desarrollo bueno descomprimen el emulador y los plugins crean una carpeta con el nombre PlugIn en donde esta el ejecutable del emulador y en esta misma carpeta pegan los archivos .so que son los plugins para linux y ya pueden activar los plugins.

DeSmuME

Tenemos que primero instalar las siguientes librerías haciendo este comando en el terminal

  sudo apt-get install build-essential autoconf automake libgtk2.0-dev  libgtkmm-2.4-dev libglu1-mesa-dev libsdl1.2-dev libglade2-dev libglademm-2.4-dev libgtkglext1-dev gettext zlib1g-dev libzzip-dev libosmesa6-dev intltool libagg-dev libasound2-dev

Descargamos el source de http://desmume.org/download/   descomprimimos y hacemos los siguientes comandos:
cd  /home/demon/Ejemplo acá colocan la dirección de donde los extrajeron
sudo ./configure
sudo make
sudo make install
Luego de instalado lo podemos abrir en aplicaciones>juegos>DeSmuMe


    Mi intención era hacer una guía sobre estos dos emuladores ya que el primero no he visto que se mencione mucho y el segundo algunos tienen problemas en la instalación acá abajo les pongo el nombre y pagina oficial de otros emuladores

    Master System/Game Gear:
    MEKA

    Genesis/Sega CD/32X:
    Gens

    sourceforge

    La web oficial se encuentra algo descuidada pero desde http://sourceforge.net podemos acceder rápidamente a las ultimas versiones. Vamos a instalar:
    1. Entrar en http://sourceforge.net/projects/gens/ y descargar la ultima versión para Debian/Ubuntu (gens_2.15.5_i386.deb) si tenemos ubuntu 64 bits lo mejor es descargarse el source code y compilarlo.
    2. Una vez descargado instalamos nuestro paquete con nuestro gestor de paquetes habitual.
    3. Tras instalarlo podemos ejecutarlo desde Aplicaciones / Juegos / Gens
    4. Para jugar, tenemos que ir a "file" y buscar la ruta hacia nuestra rom.
    Saturn:
    Yabause

    Dreamcast:
    lxdream

    Para instalarlo simplemente debes descargar el archivo que necesites para tu distro desde este link

    También puedes descargarlo a través de los repositorios oficiales.
    Primero edita la lista entrando en la terminal y tecleando:
    sudo gedit /etc/apt/sources.list
    Ingresa las siguientes lineas al final del archivo.
    deb http://www.lxdream.org/debian unstable main
    deb-src http://www.lxdream.org/debian unstable main
    Guarda y tipea
    sudo apt-get update
    sudo apt-get install lxdream
    Después debes descargar la bios y flash rom de Dreamcast.
    Busca el programa en Menu>Aplicaciones>Juegos>lxdream, seleccionalo  y se abrirá el programa, lo primero que deberás hacer es entrar en Configuración>Rutas e indicarle al programa donde se ubican los archivos bios y flash rom que descargaste.

    Con lo anterior listo deberás tener tus juegos para Dreamcast,  para jugarlo entra en Archivo>GD-Rom, donde podrás seleccionar tanto si quieres correrlos desde un cd o si quieres cargar una imagen de tipo .cdi. Seleccionado el juego haz click en play y listo estarás jugando Dreamcast en Ubuntu.

    Neo Geo:
    NeoRaine

    PlayStation:
    ePSXe
    pSX
    Pcsx
    PCSX-Reloaded Emulator basado en PCSX-df 1.9

    PlayStation 2:
    PCSX2

    Estoy intentando hacer funcionar este emulador puede que pronto ponga una guia, sobre el error al compilar then mv -f ".deps/libZeroPAD_a-linux.Tpo" ".deps/libZeroPAD_a-linux.Po"; else rm -f ".deps/libZeroPAD_a-linux.Tpo"; exit 1; fi

    Lo que hay que hacer para solucionarlo es instalar la librería libsdl1.2-dev desde el Synaptic

    La instalación en archlinux es con estos comandos:

    Instalar las librerias necesarias:
    # pacman-color -Sy  liboil cmake subversion gcc-multilib gtk2 sdl glew lib32-gtk2 lib32-sdl lib32-glew lib32-jack lib32-libxv lib32-libxml2 lib32-libcanberra
    Instalar PCSX2:
    yaourt -Sy pcsx2-svn
    Nintendo:
    FCE Ultra

    Super Nintendo:
    ZSNES

    Pagina de ROMS

    Nintendo 64:
    Mupen64

    Game Boy/Game Boy Color/Game Boy Advance:
    Visual Boy Advance

    Pueden copiar mi Tutorial siempre y cuando digan la fuente y den créditos a mí: Thedemon007

    No hay comentarios :

    Publicar un comentario